Hestan KICS series cooktop - "Cooktop is already connected to a mobile device" error : Hestan Cue Culinary Support
Submit a ticket
Welcome
Login

Hestan KICS series cooktop - "Cooktop is already connected to a mobile device" error


Hestan "KICS" series cooktops:


The following error may apply when using the Hestan Cue app: 


Error: Cooktop is already connected to a mobile device
- To use with this device to cook, quit (hard close) the Cue app on any other mobile device that may be connected.

 

Cause:

The error typically appears when another mobile device (such as another iPad, iPhone, or Android phone or tablet) in the area is already connected to the cooktop via Bluetooth. 


Solution:


  1. Locate all other mobile devices in the vicinity, and hard-close the Hestan Cue app from each one. Try again.
  2. If the issue persists, they may need to delete the Bluetooth bonds within your phone. To do so:
    1. Open the Hestan Cue app and navigate to Profile, Tap on the KICS cooptop within your device list, and choose the option to "remove cooktop." When that's done, please hard-close the app
    2. Within your mobile device "Settings" screens, navigate to the "Bluetooth" area. Once there, find your cooktop and choose to "forget device" (to unpair). 
    3. On your mobile device, Turn off Bluetooth for 5 seconds then turn it back on. Then turn on Airplane mode for 5 seconds, and turn it off
    4. Turn off your mobile device completely (full power off), then turn it back on. 
  3. If (and only if) the above steps don't work, you can delete the Bluetooth bonds within the cooktop itself. WARNING: If you complete this step, you will need to forget bonds on ALL of your mobile devices before pairing them again (step 2, above). Refer to the documentation that came with your KICS series cooktop for exact instructions.  In general, here's how:
    1. On your cooktop, tap and hold on the "Pairing Mode" button and do NOT let go.
    2. After you hear a double beep, keep holding down the button for another 3 to 5 seconds. This will wipe out all associated devices from the cooktop.


After completing the above steps, you'll need to choose the mobile device you wish to cook with, and pair the cooktop with the Hestan Cue app to enable smart cooking functions. Here's how: Hestan KICS series cooktop - Setup and pair with the Hestan Cue app

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.